logo
当前位置:首 页 > 编程技术 >后端开发 >PHP语言 > 查看文章

composer错误解决聚合

PHP语言, 后端开发, 编程技术 你是第25个围观者 0条评论 供稿者: 标签:,

国内PHP环境还是良好,配合这P2P工具【除了有些屏蔽P2P协议的公司】还是不错的,但是遇到需要composer安装的插件就有点问题了;写个集锦,谢谢解决的方法;

 

少在C盘Program Files或者其他需要最高权限的文件夹建立项目文件夹

看了许多外国的优秀项目,有写window系统使用的项目的tip或者ps中都会提前提示不要在需要最高权限的文件夹做开发或者下载,因为这样有时候都不知道问题是软甲问题还是系统权限问题

 

更换国内镜像

总所周知的原因,开发的时候会遇到些许阻碍【我家是电信移动双线用的是软路由,使用了这么久都没有遇到阻碍,不知道为何在公司用着专线,还是遇到了阻碍,不可思议的感觉】所以开始使用前可以换下国内的镜像,因为一些原因一直不信任商业化比较高的阿里云,但是没有找打国内其他大写的稳定镜像,所以先推荐阿里云的,如果哪位同仁有发现更稳定的,请一定一定邮件告诉我,地址在页脚,感谢感谢

阿里云更换代码:

 

  1. composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

取消配置的代码:

  1. composer config -g --unset repos.packagist

 

 

没有在C盘但是还是遇到了不可预测的问题

有些非C盘的文件夹也有需要系统权限的问题,有些小伙伴是直接win+r打开的运行然后输入cmd来唤出命令行工具,这样的话只有目前用户的运行权限没有最高权限,如果需要最高权限的话可以点击左下角的win图标或者键盘win键,唤出开始界面,然后再检索输入cmd,系统会显示cmd命令行软件右键选择管理员权限运行,跳出对话框选择是,就会出现最高权限CMD命令行窗口了:

下面是2个权限不同的窗口的对比,使用的时候也请主要标识,最高权限也会存在安全风险,如果不是确实需要的话请使用普通用户权限的命令行工具【这个和Linux的shell中的root权限和普通管理员权限差不多】

 

 

主要看框体上方的标题,下面的输入前的前缀路劲有可能会更改;

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

说说梦想,谈谈感悟 ,聊聊技术 https://github.com/cjx2328

—— 陈 建鑫

陈建鑫
你可能也喜欢Related Posts
footer logo
未经许可请勿自行使用、转载、修改、复制、发行、出售、发表或以其它方式利用本网站之内容。站长联系:cjx2328#126.com(修改#为@)
Copyright ©ziao design Studio All Rights Reserved.沪ICP备14052271号-3