logo
当前位置:首 页 > 编程技术 >后端开发 >docker > 查看文章

执行 yum install docker-ce docker-ce-cli containerd.io 提示:

错误:
问题: package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed

解决方法:

进入阿里云镜像地址: https://mirrors.aliyun.com/docker-ce/linux/centos/8/x86_64/stable/Packages/找到你想要的或者最新的containerd.io包,拼接在阿里云地址后面,
如下:
yum install -y https://mirrors.aliyun.com/docker-ce/linux/centos/8/x86_64/stable/Packages/containerd.io-1.4.3-3.1.el8.x86_64.rpm

然后再执行 yum install docker-ce docker-ce-cli containerd.io 即可。

说说梦想,谈谈感悟 ,聊聊技术,有啥要说的来github留言吧 https://github.com/cjx2328

—— 陈 建鑫

陈建鑫
你可能也喜欢Related Posts
footer logo
未经许可请勿自行使用、转载、修改、复制、发行、出售、发表或以其它方式利用本网站之内容。站长联系:cjx2328#126.com(修改#为@)
Copyright ©ziao Studio All Rights Reserved. E-mail:cjx2328#126.com(#号改成@) 沪ICP备14052271号-3